ATV Source.com | Calendar | ATV/UTV Reviews | ATV/UTV News | ATV/UTV Product Reviews | ATV/UTV Racing | ATV/UTV Trails | ATV/UTV Videos

ATVSource.com Social Community Forums

ATVSource.com is a social community site based on the needs of ATV/UTV fans alike.
It is currently Wed Nov 26, 2014 11:09 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Mon May 30, 2005 7:41 pm 
Offline
ATV Enthusiast Member
User avatar

Joined: Wed Dec 01, 2004 12:48 am
Posts: 206
Location: Tri-Cities, WA
Seeking any advice on the problems I'm running into with my two youth quads before I run them into the dealer.

1) Polaris Sportsman 90 won't start with the electric starter, but starts fine with the foot start. When we try the electronic ignition all I hear is a click, but nothing more. Any thoughts on what to check or is this something that just will need to be replaced?

2) Eton Viper 90 fouls plugs bad. I changed plug on Saturday after the last one fouled out, within 2 hours the second one was fouled. I gave up and parked the quad for the rest of the weekend, though I had more plugs I didn't want to be swapping them every 2 hours on the USFS trails. I checked and my son didn't have the choke on. Compared to the Sportsman 90 though the Eton seems to kick out a lot more smoke from the tail pipe.

Thanks!


Top
 Profile  
 

ADVERTISEMENT


 Post subject:
PostPosted: Mon May 30, 2005 7:50 pm 
Offline
ATV Junkie
User avatar

Joined: Tue Jun 17, 2003 1:41 pm
Posts: 541
Location: Acworth, GA
1) sounds like a bad connection or a weak battery... seems like when you are pressing the start button, the relay is clicking over to send juice to the starter, but the starter isn't turning over... check for corroded connections.

2) is this quad new? Have you run the first tank of fuel out of it yet? The dealers will add some premix oil to the first tank of gas for breakin and to get any air out of the oil injection lines. Disableing the oil injection and running premix is the way to go.

Bryce


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 30, 2005 7:50 pm 
Offline
ATV Enthusiast Member
User avatar

Joined: Wed Nov 19, 2003 6:20 pm
Posts: 237
Location: Port Neches,Tx..
Have you checked the battery on the Polaris? If the battery is good you might have corrosion in your wiring connections or your key switch.
What kind of oil are you using on the Eton? My sons used to go though plugs like that until we removed the oil injection. You might have a dirty air filter, causing a rich condition or the injection system is over oiling.


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 30, 2005 7:58 pm 
Offline
ATV Enthusiast Member
User avatar

Joined: Wed Dec 01, 2004 12:48 am
Posts: 206
Location: Tri-Cities, WA
Thanks for the quick replys, I'll go down and check things out. I appreciate the advice.


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 31, 2005 8:15 pm 
Offline
Trail Riding Member

Joined: Thu Jun 06, 2002 11:17 am
Posts: 97
Location: westminster,maryland
Hello,
The 05 eton viper has a spark arrestor in the tail pipe that gets choked up
pull it out+inspect.I seen many with problem.
Aaron


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 01, 2005 5:05 pm 
Offline
Still on the Trailer Member
User avatar

Joined: Mon Apr 25, 2005 8:55 pm
Posts: 43
Location: Ohio
On the Eton the oil injection is to blame for fouled plugs. From the factory it puts too much oil in. Remove oil injection and run premix and remove baffle in pipe wich is now surely plugged from all that oil.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 01, 2005 9:45 pm 
Offline
ATV Official
ATV Official
User avatar

Joined: Thu Aug 15, 2002 6:30 pm
Posts: 928
Location: Saraland, Alabama
Try resetting the oil injector pump.
Gain acess to the oil pump to observe when/where the cable pulls up on the oil pump. The cable should not start to pull on the oil pump until RPM's start to rise Above Idle.
Also the Rear baffle will plug when too much oil is used in the injector system. But if exhaust plugs solid no smoke will be emitted while engine is running.
Over oiled air filter/ overly dirty air filter.
Pinched tube coming off of the air box will also restrict air flow causing rich condition and plug fouling.
We have new Viper 90's and ocasionally run premix along with oil injection during breakin. With out the plug fouling problem.
The polaris click may be a starter clutch or battery problem. If its' under warranty get'er checked out.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 03, 2005 10:17 am 
Offline
ATV Enthusiast Member
User avatar

Joined: Wed Dec 01, 2004 12:48 am
Posts: 206
Location: Tri-Cities, WA
Guys I really appreciate the advice. I ran both quads to the dealer. They did suggest considering dropping the oil mix and just running premix, and I may do that if we have other problems. They were going to replace the battery in the Polaris as its also under warranty. Hopefully the Eton doesn't keep this up.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 03, 2005 11:09 pm 
Offline
Still on the Trailer Member

Joined: Mon May 30, 2005 8:10 am
Posts: 5
Don't know about an 05' 90 viper but my son has an 03' 50 viper which used to foul plugs often. I cut the rev limiter wire which is behind the front grille. that 50 runs much smoother now, and have not changed a plug in 6 months. Oil injection is still on it.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 10, 2005 10:58 am 
Offline
ATV Enthusiast Member
User avatar

Joined: Wed Dec 01, 2004 12:48 am
Posts: 206
Location: Tri-Cities, WA
Update:

The Sportsman 90 had problems with the starter, somehow water had gotten in and rusted it and locked it up. They replaced it under warranty. The odd thing is we haven't been in that deep of water, though we've hit some mud and lots of rain on one trip. It might have been when I flipped the quad up on end to pressure wash it since I didn't run the quad after washing the water may done its damage then. Dealer hasn't see that problem but the 05 maybe different than the other years. Still very odd.


Top
 Profile  
 
Display posts from previous:  Sort by  





Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: Bing [Bot]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group