ATV Source.com | Calendar | ATV/UTV Reviews | ATV/UTV News | ATV/UTV Product Reviews | ATV/UTV Racing | ATV/UTV Trails | ATV/UTV Videos

ATVSource.com Social Community Forums

ATVSource.com is a social community site based on the needs of ATV/UTV fans alike.
It is currently Mon Jun 18, 2018 6:06 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: 420 Rancher backfires
PostPosted: Sun Nov 11, 2007 6:29 pm 
Offline
Still on the Trailer Member
User avatar

Joined: Wed Oct 18, 2006 5:49 am
Posts: 7
Location: Mason, WV
My wife has a 07 Rancher 420 That backfires sometimes going downhill. It doesn't do it all the time but when it does it sounds like a cannon going off. She took it to the dealer and they changed the spark plug and said that should fix it but it didn't. any ideas you know how a woman is when her toy doesn't work right Thanks


Top
 Profile  
 

ADVERTISEMENT


 Post subject:
PostPosted: Sun Nov 11, 2007 9:59 pm 
Offline
ATVing To The End
User avatar

Joined: Fri Nov 21, 2003 4:56 pm
Posts: 3812
Location: Ohio
Look at the boots and manifold rubbers connecting carb to air box and engine. Check the clamps as well. Look at the clamp that holds the air cleaner on also. Although an occasional backfire on long engine braking periods is not unusual. It's a Honda and has a lean idle mixture for emissions
(too lean). Since it is EFI you can't tweak it.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 12, 2007 9:43 pm 
Offline
Still on the Trailer Member

Joined: Thu Mar 01, 2007 1:34 pm
Posts: 5
replace the plug, it works :grin:


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 19, 2007 6:55 pm 
Offline
Still on the Trailer Member
User avatar

Joined: Thu Jul 12, 2007 7:49 pm
Posts: 15
Just give it some time. Mine did it too. After a couple hundred miles of good break in it will stop. :wink:


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 20, 2007 9:20 pm 
Offline
Trail Riding Member

Joined: Mon Feb 12, 2007 12:36 pm
Posts: 63
Yup, our 2 420's did the same thing, not anymore. Time needed.


Top
 Profile  
 
PostPosted: Wed Jan 09, 2008 11:52 pm 
Offline
Still on the Trailer Member
User avatar

Joined: Wed Jan 09, 2008 11:48 pm
Posts: 6
Location: Oklahoma
Heck my 02 Forman still does it. lol Scares crap out of some peeps when it does. Spark plug did not fix it. My guess it is an air leak somewhere.


Top
 Profile  
 
PostPosted: Wed Nov 18, 2009 3:22 pm 
Offline
Still on the Trailer Member

Joined: Wed Nov 18, 2009 3:18 pm
Posts: 2
Mine backfires also. I will replace the plug and see if it goes away after time like yours. Also has anyone noticed a hissing sound during acceleration?


Top
 Profile  
 
Display posts from previous:  Sort by  






Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group