ATV Source.com | Calendar | ATV/UTV Reviews | ATV/UTV News | ATV/UTV Product Reviews | ATV/UTV Racing | ATV/UTV Trails | ATV/UTV Videos

ATVSource.com Social Community Forums

ATVSource.com is a social community site based on the needs of ATV/UTV fans alike.
It is currently Fri Oct 20, 2017 11:53 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sat Aug 14, 2010 6:47 pm 
Offline
ATV Enthusiast Member

Joined: Sun Jun 19, 2005 9:58 am
Posts: 107
Location: Canada
Hi.

A couple questions on the 2009 honda rancher 420 efi eps.

q1: For some odd reason the front right tire of my new 09 rancher (300 kms on it). Will not lockup in 4wd, even with the brake trick.

I went for a ride today and got into a mud hole and the only the slipping tire out of the hole got power. The right side front tire and just jambed and acted like an anchor. I switched back to 2wd was was able to get out. Nothing to attach a winch or come along to either.

My aching back!!

q2: Fuel economy. After 300 KMs my 09 rancher is still getting about 5-7mpg, which is crazy it also flooded (of sorts) when i was trying to get out of the mud hole.

Any helpful thoughts will be welcomed.

Thanks.


Top
 Profile  
 

ADVERTISEMENT


Display posts from previous:  Sort by  






Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Majestic-12 [Bot]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group